Tom Ramcigam (magicmarmot) wrote,
Tom Ramcigam
magicmarmot

New spark plugs are in. New spark plug wires are in. Engine runs beautifully now, a really amazing difference.

I have a minor oil leak from the valve cover gasket on one side. I don't think it's even worth fixing yet, though I'll keep an eye on it in case it gets worse.

The spark plugs were definitely worn. The preferred gap is .054, and the worst of the bunch was almost at .070 which would definitely be causing misfires. Nothing on the plugs to indicate other than normal wear.

What I thought was a leak in my upper radiator hose wasn't. Still don't know where the leak is, but it's really slow.

And at this point, I am off to see the wizard.
Subscribe

  • (no subject)

    Woke up to let the dog outside, and it's raining. It's 36 degrees right now, and looking at the weather, we're in a pocket that's gonna shift and…

  • (no subject)

    Hit up Micro Center for some knicknacks & doodads this morning before going to meet maatnofret for some hang time and convo, which means…

  • (no subject)

    Well, my DSL is back, and twice as fast now. Tonight was walkies, followed by a bunch of gardening, which was basically repotting the vegetable…

  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 1 comment